NFTX protocol paused
Incident Report for NFTX
Resolved
This incident has been resolved.

You can read more on https://blog.nftx.io/postmortem-nftxmarketplace0xzap-vulnerability/
Posted Sep 15, 2022 - 21:15 UTC
Monitoring
The fix has been pushed and we're unpausing the contracts now.
Posted Sep 15, 2022 - 20:54 UTC
Update
Tests have all passed and the updates to the contact has been staged on Aragon.

The next update will be when the votes are enacted in approximately 18 hours.
Posted Sep 14, 2022 - 19:57 UTC
Update
The fix has been written and is undergoing testing over the next few hours.

Once these tests have passed and the updated contracts reviewed they will be staged on Aragon. Once enacted final tests on mainnet will be conducted and if successful the contract will be unpaused and protocol use will restart.

Current estimated time for restarting the protocol is 36 hours from now (2100 UTC Thursday 15th September).
Posted Sep 14, 2022 - 09:54 UTC
Identified
We have reviewed the report into the potential vulnerability on one of the periphery contracts and can confirm the vulnerability.

Pausing the contracts means that there is no longer risk of exploitation.

A fix for the issue is being worked on now and will be tested once completed. Once the tests have passed the updates will be staged and deployed and the protocol will be re-activated.

Full postmortem will be annouced after the contracts are re-activated.
Posted Sep 13, 2022 - 21:32 UTC
Investigating
NFTX protocol is paused while we investigate a report into a potential vulnerability on a periphery contract.
Posted Sep 13, 2022 - 19:18 UTC
This incident affected: NFTX App and NFTX Vault Contracts.