Subgraph error on null date
Incident Report for NFTX
Resolved
The subgraph has been reindexed.

https://thegraph.com/explorer/subgraphs/Epp6gJotEJKAsJYdk7bDEURtGWWeZVXwZds2Pgw8eG51?view=Curators&chain=arbitrum-one

Current version v1.4.0 QmYr6m1ESfvhKuZCQxyzy51o7oDWiwGgnHXL9MRZPuVvMr
Posted Sep 02, 2024 - 21:00 UTC
Identified
Two transactions have been reviewed which has uncovered the issue.

Transaction #1: https://etherscan.io/tx/0x395710b73d2156c87b11644d10db31b97f0a7a9ffd99c49ed6e988876d9adcab

Occurred 5 days ago and was someone buying a PACA NFT from the V2 vaults through Reservoir.

Transaction #2: https://etherscan.io/tx/0xa6bbc5d76880b29dae266ce31f9113f36741cb4e9d9888007a466285c1a384bb

Occurred a few hours ago and was someone buying a PACA NFT from the V2 vaults through Reservoir. This transaction is the cause of the subgraph outage.

The events on both transactions are the same (a few differences in the token holding values of the pool, but that would be expected based on price differences).

Looking at the TokenId 559 (https://etherscan.io/token/0x3db5463a9e2d04334192c6f2dd4b72def4751a61?a=559) that was successfully bought in transaction #1, it ended up in the Vault through this transactions https://etherscan.io/tx/0xcd7bb8609e60aa2ac100ead2036eac47ed4982877003d9e4b63785e9ae1cdb2d which was a Safe Transfer (it was a sell into the NFTX vault).

Looking at Token ID 9511 (https://etherscan.io/token/0x3db5463a9e2d04334192c6f2dd4b72def4751a61?a=9511) that failed/broke the subgraph, it arrived in the vault through a "Proxy Assert" 1000+ days ago. This is likely due to someone transferring two NFTs directly into the vault instead of going through the mint/sell process, which caused the missing `dateAdded` issue. (https://etherscan.io/tx/0x594a0d7dc671c854084295a0cad461a26e3377cc37a7d1aabde1d00a0e368d52)

A fix has been deployed to remove the required value for the mint date, and the subgraph is reindexing now (est 4 hours).
Posted Sep 02, 2024 - 19:24 UTC
Investigating
The NFTX V2 subgraph has failed, we are working on a fix
Posted Sep 02, 2024 - 19:20 UTC
This incident affected: NFTX App.