Some NFT image/details not appearing
Incident Report for NFTX
Resolved
The API issue seems to be resolved now.

We are looking into making Covalent our preferred metadata API provider while potentially building our own solution that indexes directly off the contracts.
Posted Jan 21, 2022 - 12:48 UTC
Identified
OpenSea have experienced high levels of traffic and have disabled a number of API users. We have reached out to get our keys added back to the allow list and are still awaiting feedback from Opensea.
Posted Jan 20, 2022 - 23:57 UTC
Investigating
OpenSea are currently experiencing an outage on their site and API. The API issues are impacting the display of the images and some metadata around the items within the vaults.

Where we already have cached the assets you can see them, but any not cached will not load at the moment.

https://status.opensea.io/incidents/88862t31ybw5
Posted Jan 20, 2022 - 15:24 UTC
This incident affected: NFTX App.