Inventory Staking/Unstaking Issues
Incident Report for NFTX
Resolved
An update to the Inventory Staking contract has been pushed, which has fixed the temporary bug of new xTokens for existing vaults.

Users who staked inventory positions in the past 24 hours will have received the wrong xToken. NFTX will provide a way to migrate these xToken across within the 7 days you will have been locked.

Users who had previous staked positions can now unstake if you reach the end of your time lock.

Users can now stake their inventory, which will be created on the orginal xToken address.

Any fees earned during the 24 hours while the xToken address was changed will have been allocated to the DAO. The DAO will distribute these fees to the staked inventory providers based on a token-holding snapshot for each block where fees were generated. This will be actioned asap within the next two weeks.

Any gas costs for the migration from the new xToken back to the old will be reimbursed.

A full postmortem of the issue will be released to follow up on this status on https://blog.nftx.io
Posted Feb 04, 2023 - 19:43 UTC
Identified
During a recent update to the Inventory Staking contract, a change in the formatting of the contract caused the byte code hash to change. This change meant that the hash of the byte code was different to the previous version.

The hash of this byte code is used to programmatically determine the xToken address when staking NFTs into the pool, and since this was different, any new inventory staking events generated a new xToken address.

The app has temporarily disabled inventory staking/unstaking while this is being fixed.

Key points
- Your NFTs and Staked positions are safe
- We have disabled the ability to mint any staked positions on the app that differ from the OG while this is fixed
- There have been two versions of some staked positions minted due to a bug, which *does not* impact collateralization nor the ability to redeem
- There will be a review of the distribution of inventory fees to ensure that everyone receives their correct amount
Posted Feb 04, 2023 - 09:21 UTC
Update
Any new inventory staking have been created using a new xToken address following an update earlier today. While your positions are still the same as before, we are investigating if rewards will be distributed to these addresses and ensure that the marketplace and yield apps correctly show your positions.

The apps are currently only pulling through the existing xToken addresses, so any new staked items in the past 12 hours will not be visible through the app.
Posted Feb 04, 2023 - 02:33 UTC
Investigating
We are experiencing issues with the front-end display of Inventory Staking positions at the moment.

Investigations are ongoing, and updates will be provided as more details are discovered.
Posted Feb 04, 2023 - 01:51 UTC
This incident affected: NFTX App.