Subgraph Outage
Incident Report for NFTX
Resolved
This incident has been resolved.
Posted Jan 28, 2023 - 22:48 UTC
Identified
On the CoolCats vault, there was a swap 360 days ago for an item that the user didn't own. This was done directly on Etherscan (otherwise they couldn't do it on the UI), and instead of failing the contract emitted events that made it look like the id was added to the vault and then removed.

As a result of this transaction one of the CoolCats was in the vault but not listed as one of the holdings.

Earlier today someone swapped the CoolCat out of the vault which caused the subgraph indexing to fail — it was trying to put a date against an item that was removed that the subgraph thought wasn't in the vault, and NULL wasn't an accepted value against the date.

To fix the issue we have made the `dateAdded` field on the subgraph an optional field, and the subgraph is working again.

The new deployment is `QmeeGQ9xzXRf2vsYwi9MkuU8i4om6R9GUDhdp9q7j4oZyV`, and the decentralised graph and the hosted endpoint have both been updated.
Posted Jan 28, 2023 - 22:47 UTC
Investigating
The subgraph providing the data on the site has stopped indexing on block 16506629 after a swap transaction caused an error.

We are looking into making an update to this to allow the syncing to resume.

This is impacting the updated display for most areas on the site including
- current holdings on vaults
- new vaults
- activity (buy/sell/swap)
- staking/unstaking positions

Any actions on the site (buying/selling/staking/swapping) will still work, but the results won't appear on the site until the bug is fixed on the subgraph.
Posted Jan 28, 2023 - 20:34 UTC
This incident affected: NFTX App.